{"id":"CVE-2016-20103","title":"Cherry Plugin for WordPress < 1.2.7 Path Traversal via download-content.php","summary":"Cherry Plugin for WordPress before 1.2.7 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the 'file' parameter. Attackers can send GET requests to /admin/import-export/download…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","cvssSource":"cna","cwe":["CWE-22"],"vendor":"Cherry Team","product":"Cherry Plugin","affected":["cherry_plugin >= 1.1 < 1.2.7"],"ssvc":{"exploitation":"poc","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-28T15:56:42.646462Z"},"exploitAvailable":true,"published":"2026-10-20","updated":"2026-10-28","sourceUpdated":"2026-10-28T15:57:22.592Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2016-20103","references":[{"url":"https://wpscan.com/vulnerability/90034817-dee7-40c9-80a2-1f1cd1d033ee","label":"WPScan 90034817"},{"url":"https://github.com/CherryFramework/cherry-plugin/commit/69a3f7b","label":"Patch Commit"},{"url":"https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/cherry-file-download.yaml","label":"Nuclei Template"},{"url":"https://www.vulncheck.com/advisories/cherry-plugin-for-wordpress-1.2.7-path-traversal-via-download-content-php","label":"VulnCheck Advisory: Cherry Plugin for WordPress < 1.2.7 Path Traversal via download-content.php"}],"tags":["cve.org","exploit-available"],"epss":0.00389,"epssPercentile":0.32942,"ingestedAt":"2026-10-20T21:19:21.265Z","slug":"CVE-2016-20103","body":"## Overview\n\nCherry Plugin for WordPress before 1.2.7 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the 'file' parameter. Attackers can send GET requests to /admin/import-export/download-content.php with traversal sequences like ../../../../../wp-config.php to read database credentials, since the script passes input directly to readfile(). Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.\n\n## Affected\n\n- `cherry_plugin >= 1.1 < 1.2.7`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"midnight","depthScore":53,"depthScoreParts":{"impact":41.3,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":230698,"id":"CVE-2016-20103","ts":1793204065269,"field":"exploit_available","old":"false","new":"true"}]}