{"id":"CVE-2017-20251","title":"WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API","summary":"WordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers …","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-94"],"vendor":"Themeisle","product":"Woody Code Snippets","affected":["woody_code_snippets < 3.3.1"],"ssvc":{"exploitation":"poc","automatable":"yes","technicalImpact":"total","timestamp":"2026-06-09T16:13:44.753300Z"},"exploitAvailable":true,"published":"2026-06-09","updated":"2026-10-29","sourceUpdated":"2026-10-29T21:15:00.988Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2017-20251","references":[{"url":"https://www.exploit-db.com/exploits/41308","label":"ExploitDB-41308"},{"url":"https://fr.wordpress.org/plugins/insert-php/","label":"Official Product Homepage"},{"url":"https://www.vulncheck.com/advisories/wordpress-insert-php-plugin-php-code-injection-via-rest-api","label":"VulnCheck Advisory: WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API"}],"tags":["cve.org","exploit-available"],"epss":0.00559,"epssPercentile":0.46524,"exploits":{"github":1,"githubRepos":["https://github.com/Polosss/By-Poloss..-..CVE-2017-20251"],"checkedAt":"2026-11-03T08:40:12.830Z"},"ingestedAt":"2026-11-03T08:39:35.530Z","slug":"CVE-2017-20251","body":"## Overview\n\nWordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers can send POST requests to the wp-json/wp/v2/posts endpoint with crafted content containing insert_php shortcodes to include and execute remote PHP files on the server.\n\n## Affected\n\n- `woody_code_snippets < 3.3.1`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"abyssal","depthScore":66,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[]}