{"id":"CVE-2022-2175","title":"Buffer Over-read in GitHub repository vim/vim prior to 8.2.","summary":"Buffer Over-read in GitHub repository vim/vim prior to 8.2.","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","cwe":["CWE-126","CWE-125"],"vendor":"vim","product":"vim","affected":["vim < 8.2.5148","fedora = 35","fedora = 36"],"patched":["vim 8.2.5148"],"published":"2022-06-23","updated":"2026-10-08","sourceUpdated":"2026-10-08T21:17:46.110","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2022-2175","references":[{"url":"https://github.com/vim/vim/commit/6046aded8da002b08d380db29de2ba0268b6616e","label":"security@huntr.dev"},{"url":"https://huntr.dev/bounties/7f0481c2-8b57-4324-b47c-795d1ea67e55","label":"security@huntr.dev"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/","label":"security@huntr.dev"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/","label":"security@huntr.dev"},{"url":"https://security.gentoo.org/glsa/202208-32","label":"security@huntr.dev"},{"url":"https://security.gentoo.org/glsa/202305-16","label":"security@huntr.dev"},{"url":"https://github.com/vim/vim/commit/6046aded8da002b08d380db29de2ba0268b6616e","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://huntr.dev/bounties/7f0481c2-8b57-4324-b47c-795d1ea67e55","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.gentoo.org/glsa/202208-32","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.gentoo.org/glsa/202305-16","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-2175.json"},{"url":"https://access.redhat.com/security/cve/CVE-2022-2175"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2101293"},{"url":"https://www.cve.org/CVERecord?id=CVE-2022-2175"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2022-2175"}],"tags":["nvd","csaf","vex","red-hat","cve.org"],"epss":0.01314,"epssPercentile":0.70577,"ingestedAt":"2026-10-08T22:11:53.753Z","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-10-08T20:53:12.852622Z"},"slug":"CVE-2022-2175","body":"## Overview\n\nBuffer Over-read in GitHub repository vim/vim prior to 8.2.\n\n## Affected\n\n- `vim < 8.2.5148`\n- `fedora = 35`\n- `fedora = 36`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `vim 8.2.5148`\n\n## Vendor advisories\n\n- **Red Hat VEX** · Low · affected: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · updated 2026-10-08 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-2175.json)","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0.3,"exploitation":0,"ransomware":0},"changes":[]}