{"id":"CVE-2022-2287","title":"Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.","summary":"Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.","severity":"high","cvss":7.1,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H","cwe":["CWE-125"],"vendor":"vim","product":"vim","affected":["vim < 9.0.0021","fedora = 35","fedora = 36"],"patched":["vim 9.0.0021"],"published":"2022-07-02","updated":"2026-10-08","sourceUpdated":"2026-10-08T21:17:47.793","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2022-2287","references":[{"url":"https://github.com/vim/vim/commit/5e59ea54c0c37c2f84770f068d95280069828774","label":"security@huntr.dev"},{"url":"https://huntr.dev/bounties/654aa069-3a9d-45d3-9a52-c1cf3490c284","label":"security@huntr.dev"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/","label":"security@huntr.dev"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/","label":"security@huntr.dev"},{"url":"https://security.gentoo.org/glsa/202208-32","label":"security@huntr.dev"},{"url":"https://security.gentoo.org/glsa/202305-16","label":"security@huntr.dev"},{"url":"https://github.com/vim/vim/commit/5e59ea54c0c37c2f84770f068d95280069828774","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://huntr.dev/bounties/654aa069-3a9d-45d3-9a52-c1cf3490c284","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.gentoo.org/glsa/202208-32","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.gentoo.org/glsa/202305-16","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-2287.json"},{"url":"https://access.redhat.com/security/cve/CVE-2022-2287"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2103876"},{"url":"https://www.cve.org/CVERecord?id=CVE-2022-2287"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2022-2287"}],"tags":["nvd","csaf","vex","red-hat","cve.org"],"epss":0.0139,"epssPercentile":0.72178,"ingestedAt":"2026-10-08T22:11:53.756Z","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-08T20:53:47.961188Z"},"scores":{"nvd":7.1,"cna":8},"slug":"CVE-2022-2287","body":"## Overview\n\nOut-of-bounds Read in GitHub repository vim/vim prior to 9.0.\n\n## Affected\n\n- `vim < 9.0.0021`\n- `fedora = 35`\n- `fedora = 36`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `vim 9.0.0021`\n\n## Vendor advisories\n\n- **Red Hat VEX** · Low · affected: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · updated 2026-10-08 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-2287.json)","depth":"twilight","depthScore":39,"depthScoreParts":{"impact":39.1,"likelihood":0.3,"exploitation":0,"ransomware":0},"changes":[]}