{"id":"CVE-2023-22884","aliases":["GHSA-c732-xvv8-g94c","BIT-airflow-2023-22884","PYSEC-2026-268","PYSEC-2026-279"],"title":"Command Injection in Apache Airflow and Apache Airflow MySQL Provider","summary":"Command Injection in Apache Airflow and Apache Airflow MySQL Provider","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","vendor":"apache-airflow","product":"apache-airflow","ecosystem":"pip","affected":["apache-airflow < 2.5.1","apache-airflow-providers-mysql < 4.0.0"],"patched":["apache-airflow 2.5.1","apache-airflow-providers-mysql 4.0.0"],"published":"2023-01-21","updated":"2026-10-27","sourceUpdated":"2026-10-27T15:30:04.385983829Z","source":"OSV","sourceUrl":"https://osv.dev/vulnerability/GHSA-c732-xvv8-g94c","references":[{"url":"https://nvd.nist.gov/vuln/detail/CVE-2023-22884"},{"url":"https://github.com/apache/airflow/pull/28811"},{"url":"https://github.com/apache/airflow"},{"url":"https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-mysql/PYSEC-2026-279.yaml"},{"url":"https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-268.yaml"},{"url":"https://lists.apache.org/thread/0l0j3nt0t7fzrcjl2ch0jgj6c58kxs5h"},{"url":"https://pypi.org/project/apache-airflow"},{"url":"https://pypi.org/project/apache-airflow-providers-mysql"},{"url":"https://github.com/advisories/GHSA-c732-xvv8-g94c"}],"tags":["osv","pip","exploit-available","ghsa"],"epss":0.11082,"epssPercentile":0.95898,"exploits":{"github":1,"githubRepos":["https://github.com/jakabakos/CVE-2023-22884-Airflow-SQLi"],"checkedAt":"2026-10-27T16:20:47.577Z"},"exploitAvailable":true,"cwe":["CWE-77"],"ingestedAt":"2026-10-27T16:11:58.737Z","slug":"CVE-2023-22884","body":"## Overview\n\nImproper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.\n\n## Affected packages\n\n- `apache-airflow < 2.5.1`\n- `apache-airflow-providers-mysql < 4.0.0`\n\n## Remediation\n\nUpgrade to a patched release:\n\n- `apache-airflow 2.5.1`\n- `apache-airflow-providers-mysql 4.0.0`","depth":"abyssal","depthScore":68,"depthScoreParts":{"impact":53.9,"likelihood":2.2,"exploitation":12,"ransomware":0},"changes":[]}