{"id":"CVE-2023-25691","aliases":["GHSA-8g23-2q5p-8866","PYSEC-2026-277"],"title":"Apache Airflow Google Provider Improper Input Validation vulnerability","summary":"Apache Airflow Google Provider Improper Input Validation vulnerability","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","vendor":"apache-airflow-providers-google","product":"apache-airflow-providers-google","ecosystem":"pip","affected":["apache-airflow-providers-google < 8.10.0"],"patched":["apache-airflow-providers-google 8.10.0"],"published":"2023-02-24","updated":"2026-10-26","sourceUpdated":"2026-10-26T21:30:04.157195437Z","source":"OSV","sourceUrl":"https://osv.dev/vulnerability/GHSA-8g23-2q5p-8866","references":[{"url":"https://nvd.nist.gov/vuln/detail/CVE-2023-25691"},{"url":"https://github.com/apache/airflow/pull/29497"},{"url":"https://github.com/apache/airflow"},{"url":"https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-google/PYSEC-2026-277.yaml"},{"url":"https://lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy"},{"url":"https://pypi.org/project/apache-airflow-providers-google"},{"url":"https://github.com/advisories/GHSA-8g23-2q5p-8866"}],"tags":["osv","pip","ghsa"],"epss":0.01597,"epssPercentile":0.75619,"cwe":["CWE-20"],"ingestedAt":"2026-10-27T16:11:58.771Z","slug":"CVE-2023-25691","body":"## Overview\n\nImproper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.\n\n## Affected packages\n\n- `apache-airflow-providers-google < 8.10.0`\n\n## Remediation\n\nUpgrade to a patched release:\n\n- `apache-airflow-providers-google 8.10.0`","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.3,"exploitation":0,"ransomware":0},"changes":[]}