{"id":"CVE-2023-25696","aliases":["GHSA-9mwf-mw74-9cv5","PYSEC-2026-272"],"title":"Apache Airflow Hive Provider Improper Input Validation vulnerability","summary":"Apache Airflow Hive Provider Improper Input Validation vulnerability","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","vendor":"apache-airflow-providers-apache-hive","product":"apache-airflow-providers-apache-hive","ecosystem":"pip","affected":["apache-airflow-providers-apache-hive < 5.1.3"],"patched":["apache-airflow-providers-apache-hive 5.1.3"],"published":"2023-02-24","updated":"2026-10-26","sourceUpdated":"2026-10-26T21:15:03.631552813Z","source":"OSV","sourceUrl":"https://osv.dev/vulnerability/GHSA-9mwf-mw74-9cv5","references":[{"url":"https://nvd.nist.gov/vuln/detail/CVE-2023-25696"},{"url":"https://github.com/apache/airflow/pull/29502"},{"url":"https://github.com/apache/airflow"},{"url":"https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-hive/PYSEC-2026-272.yaml"},{"url":"https://lists.apache.org/thread/99g0qm56wmgdxmbtdsvhj4rdnxhpzpml"},{"url":"https://pypi.org/project/apache-airflow-providers-apache-hive"},{"url":"https://github.com/advisories/GHSA-9mwf-mw74-9cv5"}],"tags":["osv","pip","ghsa"],"epss":0.01982,"epssPercentile":0.80455,"cwe":["CWE-20"],"ingestedAt":"2026-10-27T16:11:58.779Z","slug":"CVE-2023-25696","body":"## Overview\n\nImproper Input Validation vulnerability in the Apache Airflow Hive Provider. This issue affects Apache Airflow Hive Provider versions before 5.1.3.\n\n## Affected packages\n\n- `apache-airflow-providers-apache-hive < 5.1.3`\n\n## Remediation\n\nUpgrade to a patched release:\n\n- `apache-airflow-providers-apache-hive 5.1.3`","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.4,"exploitation":0,"ransomware":0},"changes":[]}