{"id":"CVE-2024-22274","title":"The vCenter Server contains an authenticated remote code execution vulnerability. A malicious actor with administrative privileges on the vCenter appliance shell may exploit this issue to run arbitrary commands on the underlying operatin…","summary":"The vCenter Server contains an authenticated remote code execution vulnerability. A malicious actor with administrative privileges on the vCenter appliance shell may exploit this issue to run arbitrary commands on the underlying operatin…","severity":"high","cvss":7.2,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-94"],"vendor":"vmware","product":"cloud_foundation","affected":["cloud_foundation >= 4.0, < 5.1.1","vcenter_server = 7.0","vcenter_server = 8.0"],"patched":["cloud_foundation 5.1.1"],"published":"2024-05-21","updated":"2026-11-03","sourceUpdated":"2026-11-03T22:17:13.933","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2024-22274","references":[{"url":"https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24308","label":"security@vmware.com"},{"url":"https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24308","label":"af854a3a-2127-422b-91ae-364da2661108"}],"tags":["nvd","cve.org","exploit-available"],"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2024-07-11T03:55:31.943295Z"},"epss":0.02509,"epssPercentile":0.84855,"exploits":{"github":4,"githubRepos":["https://github.com/mbadanoiu/CVE-2024-22274","https://github.com/ninhpn1337/CVE-2024-22274","https://github.com/l0n3m4n/CVE-2024-22274-RCE"],"checkedAt":"2026-11-07T17:43:56.909Z"},"ingestedAt":"2026-11-05T06:38:03.564Z","slug":"CVE-2024-22274","body":"## Overview\n\nThe vCenter Server contains an authenticated remote code execution vulnerability. A malicious actor with administrative privileges on the vCenter appliance shell may exploit this issue to run arbitrary commands on the underlying operating system.\n\n## Affected\n\n- `cloud_foundation >= 4.0, < 5.1.1`\n- `vcenter_server = 7.0`\n- `vcenter_server = 8.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `cloud_foundation 5.1.1`","depth":"midnight","depthScore":52,"depthScoreParts":{"impact":39.6,"likelihood":0.5,"exploitation":12,"ransomware":0},"changes":[]}