{"id":"CVE-2024-27903","title":"OpenVPN plug-ins on Windows with OpenVPN 2.6.9 and earlier could be loaded from any directory, which allows an attacker to load an arbitrary plug-in which can be used to interact with the privileged OpenVPN interactive service.","summary":"OpenVPN plug-ins on Windows with OpenVPN 2.6.9 and earlier could be loaded from any directory, which allows an attacker to load an arbitrary plug-in which can be used to interact with the privileged OpenVPN interactive service.","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-283","CWE-434"],"vendor":"openvpn","product":"openvpn","affected":["openvpn < 2.5.10","openvpn >= 2.6.0, < 2.6.10"],"patched":["openvpn 2.6.10"],"published":"2024-07-08","updated":"2026-11-03","sourceUpdated":"2026-11-03T22:17:16.907","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2024-27903","references":[{"url":"https://community.openvpn.net/openvpn/wiki/CVE-2024-27903","label":"security@openvpn.net"},{"url":"https://openvpn.net/security-advisory/ovpnx-vulnerability-cve-2024-27903-cve-2024-27459-cve-2024-24974/","label":"security@openvpn.net"},{"url":"https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07534.html","label":"security@openvpn.net"},{"url":"https://community.openvpn.net/openvpn/wiki/CVE-2024-27903","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://openvpn.net/security-advisory/ovpnx-vulnerability-cve-2024-27903-cve-2024-27459-cve-2024-24974/","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07534.html","label":"af854a3a-2127-422b-91ae-364da2661108"}],"tags":["nvd","cve.org","score-dispute"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2024-08-23T03:55:36.482126Z"},"scores":{"nvd":9.8,"adp":7.2},"epss":0.08922,"epssPercentile":0.95269,"ingestedAt":"2026-11-05T06:38:03.572Z","slug":"CVE-2024-27903","body":"## Overview\n\nOpenVPN plug-ins on Windows with OpenVPN 2.6.9 and earlier could be loaded from any directory, which allows an attacker to load an arbitrary plug-in which can be used to interact with the privileged OpenVPN interactive service.\n\n## Affected\n\n- `openvpn < 2.5.10`\n- `openvpn >= 2.6.0, < 2.6.10`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `openvpn 2.6.10`","depth":"midnight","depthScore":56,"depthScoreParts":{"impact":53.9,"likelihood":1.8,"exploitation":0,"ransomware":0},"changes":[]}