{"id":"CVE-2024-6239","title":"Poppler: pdfinfo: crash in broken documents when using -dests parameter","summary":"A flaw was found in the Poppler's Pdfinfo utility. This issue occurs when using -dests parameter with pdfinfo utility. By using certain malformed input files, an attacker could cause the utility to crash, leading to a denial of service.","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cvssSource":"cna","cwe":["CWE-20"],"vendor":"Red Hat","product":"poppler","affected":["poppler >= 24.06.0 <= 24.06.1","poppler (all versions)","poppler (all versions)","poppler","poppler","compat-poppler022","poppler","gimp:flatpak/poppler (all versions)","inkscape:flatpak/poppler (all versions)","libreoffice:flatpak/poppler (all versions)","inkscape:flatpak/poppler (all versions)","libreoffice:flatpak/poppler (all versions)"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2024-06-24T15:14:35.733533Z"},"published":"2024-06-21","updated":"2026-11-06","sourceUpdated":"2026-11-06T20:34:53.365Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2024-6239","references":[{"url":"https://access.redhat.com/errata/RHSA-2024:5305","label":"RHSA-2024:5305"},{"url":"https://access.redhat.com/errata/RHSA-2024:9167","label":"RHSA-2024:9167"},{"url":"https://access.redhat.com/security/cve/CVE-2024-6239"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2293594","label":"RHBZ#2293594"}],"tags":["cve.org"],"epss":0.00785,"epssPercentile":0.5631,"ingestedAt":"2026-11-06T21:04:04.246Z","slug":"CVE-2024-6239","body":"## Overview\n\nA flaw was found in the Poppler's Pdfinfo utility. This issue occurs when using -dests parameter with pdfinfo utility. By using certain malformed input files, an attacker could cause the utility to crash, leading to a denial of service.\n\n## Affected\n\n- `poppler >= 24.06.0 <= 24.06.1`\n- `poppler (all versions)`\n- `poppler (all versions)`\n- `poppler`\n- `poppler`\n- `compat-poppler022`\n- `poppler`\n- `gimp:flatpak/poppler (all versions)`\n- `inkscape:flatpak/poppler (all versions)`\n- `libreoffice:flatpak/poppler (all versions)`\n- `inkscape:flatpak/poppler (all versions)`\n- `libreoffice:flatpak/poppler (all versions)`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":41.3,"likelihood":0.2,"exploitation":0,"ransomware":0},"changes":[]}