{"id":"CVE-2025-12720","title":"The g-FFL Cockpit plugin for WordPress is vulnerable to unauthorized modification of data due to IP-based authorization that can be spoofed in the handle_enqueue_only() function in all versions up to, and including, 1.7.1","summary":"The g-FFL Cockpit plugin for WordPress is vulnerable to unauthorized modification of data due to IP-based authorization that can be spoofed in the handle_enqueue_only() function in all versions up to, and including, 1.7.1. This makes it …","severity":"medium","cvss":5.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","cwe":["CWE-285"],"published":"2025-12-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T20:10:00.197","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-12720","references":[{"url":"https://github.com/d0n601/CVE-2025-12720","label":"security@wordfence.com"},{"url":"https://plugins.trac.wordpress.org/browser/g-ffl-cockpit/trunk/includes/class-update-processor.php#L634","label":"security@wordfence.com"},{"url":"https://plugins.trac.wordpress.org/changeset/3413768/","label":"security@wordfence.com"},{"url":"https://ryankozak.com/posts/cve-2025-12720/","label":"security@wordfence.com"},{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/3405974d-cf0a-4fef-9693-5d81833f42d6?source=cve","label":"security@wordfence.com"}],"tags":["nvd","exploit-available"],"epss":0.00279,"epssPercentile":0.20231,"exploits":{"github":1,"githubRepos":["https://github.com/d0n601/CVE-2025-12720"],"checkedAt":"2026-10-27T18:12:44.906Z"},"exploitAvailable":true,"ingestedAt":"2026-10-27T18:12:09.287Z","slug":"CVE-2025-12720","body":"## Overview\n\nThe g-FFL Cockpit plugin for WordPress is vulnerable to unauthorized modification of data due to IP-based authorization that can be spoofed in the handle_enqueue_only() function in all versions up to, and including, 1.7.1. This makes it possible for unauthenticated attackers to delete arbitrary products.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":29.2,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[]}