{"id":"CVE-2025-12763","title":"pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems","summary":"pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system command…","severity":"medium","cvss":6.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H","cwe":["CWE-78"],"vendor":"pgadmin","product":"pgadmin_4","affected":["pgadmin_4 < 9.10"],"patched":["pgadmin_4 9.10"],"published":"2025-11-13","updated":"2026-10-07","sourceUpdated":"2026-10-07T21:10:00.200","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-12763","references":[{"url":"https://github.com/pgadmin-org/pgadmin4/issues/9323","label":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-12763"},{"url":"https://github.com/pgadmin-org/pgadmin4/commit/e374edc69239b3e02ecde895e27d9f9e488b87ee"},{"url":"https://github.com/pgadmin-org/pgadmin4"}],"tags":["nvd","osv","pip"],"epss":0.00914,"epssPercentile":0.59942,"aliases":["GHSA-rm79-x4g6-hvg5","PYSEC-2026-1776"],"ecosystem":"pip","ingestedAt":"2026-07-08T18:25:52.955Z","slug":"CVE-2025-12763","body":"## Overview\n\npgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.\n\n## Affected\n\n- `pgadmin_4 < 9.10`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `pgadmin_4 9.10`\n\n## Package advisory (CVE-2025-12763)\n\nAffected packages:\n\n- `pgadmin4 < 9.10`\n\nPatched in:\n\n- `pgadmin4 9.10`\n\nSource: https://osv.dev/vulnerability/GHSA-rm79-x4g6-hvg5","depth":"sunlit","depthScore":38,"depthScoreParts":{"impact":37.4,"likelihood":0.2,"exploitation":0,"ransomware":0},"changes":[]}