{"id":"CVE-2025-14437","title":"The Hummingbird Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.18.0 via the 'request' function","summary":"The Hummingbird Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.18.0 via the 'request' function. This makes it possible for unauthenticated attackers to extract sen…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","cwe":["CWE-532"],"published":"2025-12-18","updated":"2026-10-01","sourceUpdated":"2026-10-01T16:10:00.257","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-14437","references":[{"url":"https://plugins.trac.wordpress.org/changeset/3421187/hummingbird-performance","label":"security@wordfence.com"},{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/8755ab3f-ee77-44ea-8620-590f1f1cb333?source=cve","label":"security@wordfence.com"}],"tags":["nvd","exploit-available"],"epss":0.01834,"epssPercentile":0.78805,"exploits":{"nuclei":["CVE-2025-14437"],"checkedAt":"2026-10-27T16:45:13.363Z"},"exploitAvailable":true,"ingestedAt":"2026-10-01T18:55:42.307Z","slug":"CVE-2025-14437","body":"## Overview\n\nThe Hummingbird Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.18.0 via the 'request' function. This makes it possible for unauthenticated attackers to extract sensitive data including Cloudflare API credentials.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":41.3,"likelihood":0.4,"exploitation":12,"ransomware":0},"changes":[]}