{"id":"CVE-2025-14546","title":"Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback","summary":"Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows f…","severity":"medium","cvss":6.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N","cwe":["CWE-285"],"vendor":"fastapi-sso","product":"fastapi-sso","affected":["fastapi-sso < 0.19.0"],"patched":["fastapi-sso 0.19.0"],"published":"2025-12-19","updated":"2026-10-13","sourceUpdated":"2026-10-13T11:10:00.203","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-14546","references":[{"url":"https://github.com/tomasvotava/fastapi-sso/commit/6117d1a5ad498ba57d671e8a059ebe20db5abe02","label":"report@snyk.io"},{"url":"https://github.com/tomasvotava/fastapi-sso/issues/266","label":"report@snyk.io"},{"url":"https://security.snyk.io/vuln/SNYK-PYTHON-FASTAPISSO-14386403","label":"report@snyk.io"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-14546"},{"url":"https://github.com/tomasvotava/fastapi-sso"}],"tags":["nvd","osv","pip"],"epss":0.00359,"epssPercentile":0.29433,"aliases":["GHSA-hp6r-r9vc-q8wx","PYSEC-2026-1362"],"ecosystem":"pip","ingestedAt":"2026-07-08T18:25:50.293Z","slug":"CVE-2025-14546","body":"## Overview\n\nVersions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verify_and_process method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2025-14546)\n\nAffected packages:\n\n- `fastapi-sso < 0.19.0`\n\nPatched in:\n\n- `fastapi-sso 0.19.0`\n\nSource: https://osv.dev/vulnerability/GHSA-hp6r-r9vc-q8wx","depth":"sunlit","depthScore":35,"depthScoreParts":{"impact":34.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}