{"id":"CVE-2025-21704","title":"In the Linux kernel, the following vulnerability has been resolved:\n\nusb: cdc-acm: Check control transfer buffer size before access\n\nIf the first fragment is shorter than struct usb_cdc_notification, we can't\ncalculate an expected_size","summary":"In the Linux kernel, the following vulnerability has been resolved:\n\nusb: cdc-acm: Check control transfer buffer size before access\n\nIf the first fragment is shorter than struct usb_cdc_notification, we can't\ncalculate an expected_size. …","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-787"],"vendor":"linux","product":"linux_kernel","affected":["linux_kernel >= 2.6.13, < 5.4.291","linux_kernel >= 5.5, < 5.10.235","linux_kernel >= 5.11, < 5.15.179","linux_kernel >= 5.16, < 6.1.129","linux_kernel >= 6.2, < 6.6.79","linux_kernel >= 6.7, < 6.12.16","linux_kernel >= 6.13, < 6.13.4","linux_kernel = 2.6.12","linux_kernel = 6.14"],"patched":["linux_kernel 6.13.4"],"published":"2025-02-22","updated":"2026-10-15","sourceUpdated":"2026-10-15T02:17:28.313","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-21704","references":[{"url":"https://git.kernel.org/stable/c/383d516a0ebc8641372b521c8cb717f0f1834831","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/6abb510251e75f875797d8983a830e6731fa281c","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/7828e9363ac4d23b02419bf2a45b9f1d9fb35646","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/871619c2b78fdfe05afb4e8ba548678687beb812","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/90dd2f1b7342b9a671a5ea4160f408037b92b118","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/a4e1ae5c0533964170197e4fb4f33bc8c1db5cd2","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/e563b01208f4d1f609bcab13333b6c0e24ce6a01","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/f64079bef6a8a7823358c3f352ea29a617844636","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://project-zero.issues.chromium.org/issues/395107243","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://cert-portal.siemens.com/productcert/html/ssa-265688.html","label":"0b142b55-0307-4c5a-b3c9-f314f3fb7c5e"},{"url":"https://cert-portal.siemens.com/productcert/html/ssa-784472.html","label":"0b142b55-0307-4c5a-b3c9-f314f3fb7c5e"}],"tags":["nvd","cve.org"],"epss":0.00368,"epssPercentile":0.30524,"ingestedAt":"2026-10-15T03:30:12.785Z","slug":"CVE-2025-21704","body":"## Overview\n\nIn the Linux kernel, the following vulnerability has been resolved:\n\nusb: cdc-acm: Check control transfer buffer size before access\n\nIf the first fragment is shorter than struct usb_cdc_notification, we can't\ncalculate an expected_size. Log an error and discard the notification\ninstead of reading lengths from memory outside the received data, which can\nlead to memory corruption when the expected_size decreases between\nfragments, causing `expected_size - acm->nb_index` to wrap.\n\nThis issue has been present since the beginning of git history; however,\nit only leads to memory corruption since commit ea2583529cd1\n(\"cdc-acm: reassemble fragmented notifications\").\n\nA mitigating factor is that acm_ctrl_irq() can only execute after userspace\nhas opened /dev/ttyACM*; but if ModemManager is running, ModemManager will\ndo that automatically depending on the USB device's vendor/product IDs and\nits other interfaces.\n\n## Affected\n\n- `linux_kernel >= 2.6.13, < 5.4.291`\n- `linux_kernel >= 5.5, < 5.10.235`\n- `linux_kernel >= 5.11, < 5.15.179`\n- `linux_kernel >= 5.16, < 6.1.129`\n- `linux_kernel >= 6.2, < 6.6.79`\n- `linux_kernel >= 6.7, < 6.12.16`\n- `linux_kernel >= 6.13, < 6.13.4`\n- `linux_kernel = 2.6.12`\n- `linux_kernel = 6.14`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `linux_kernel 6.13.4`","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}