{"id":"CVE-2025-30299","title":"Adobe Framemaker | Heap-based Buffer Overflow (CWE-122)","summary":"Adobe Framemaker versions 2020.8, 2022.6 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user in…","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-122"],"vendor":"Adobe","product":"Adobe Framemaker","affected":["framemaker <= 2022.6"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2025-04-09T04:01:14.750579Z"},"published":"2025-04-08","updated":"2026-11-03","sourceUpdated":"2026-11-03T22:02:57.632Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2025-30299","references":[{"url":"https://helpx.adobe.com/security/products/framemaker/apsb25-33.html"}],"tags":["cve.org"],"epss":0.00275,"epssPercentile":0.19978,"ingestedAt":"2026-11-05T20:33:06.549Z","slug":"CVE-2025-30299","body":"## Overview\n\nAdobe Framemaker versions 2020.8, 2022.6 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.\n\n## Affected\n\n- `framemaker <= 2022.6`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}