{"id":"CVE-2025-34290","title":"Versa SASE Client for Windows versions released between 7.8.7 and 7.9.4 contain a local privilege escalation vulnerability in the audit log export functionality","summary":"Versa SASE Client for Windows versions released between 7.8.7 and 7.9.4 contain a local privilege escalation vulnerability in the audit log export functionality. The client communicates user-controlled file paths to a privileged service,…","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-250","CWE-367"],"vendor":"versa-networks","product":"sase_client","affected":["sase_client >= 7.8.7, < 7.9.5"],"patched":["sase_client 7.9.5"],"published":"2025-12-20","updated":"2026-10-07","sourceUpdated":"2026-10-07T13:10:00.713","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-34290","references":[{"url":"https://security-portal.versa-networks.com/emailbulletins/69421e33d03aafc8e5bdaf21","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/versa-sase-client-for-windows-arbitrary-file-deletion-leading-to-lpe","label":"disclosure@vulncheck.com"}],"tags":["nvd"],"epss":0.00107,"epssPercentile":0.01134,"ingestedAt":"2026-08-24T21:11:23.913Z","slug":"CVE-2025-34290","body":"## Overview\n\nVersa SASE Client for Windows versions released between 7.8.7 and 7.9.4 contain a local privilege escalation vulnerability in the audit log export functionality. The client communicates user-controlled file paths to a privileged service, which performs file system operations without impersonating the requesting user. Due to improper privilege handling and a time-of-check time-of-use race condition combined with symbolic link and mount point manipulation, a local authenticated attacker can coerce the service into deleting arbitrary directories with SYSTEM privileges. This can be exploited to delete protected system folders such as C:\\\\Config.msi and subsequently achieve execution as NT AUTHORITY\\\\SYSTEM via MSI rollback techniques.\n\n## Affected\n\n- `sase_client >= 7.8.7, < 7.9.5`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `sase_client 7.9.5`","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":217507,"id":"CVE-2025-34290","ts":1791379900125,"field":"cvss","old":null,"new":"7.8"},{"seq":217506,"id":"CVE-2025-34290","ts":1791379900125,"field":"severity","old":"none","new":"high"}]}