{"id":"CVE-2025-38270","title":"In the Linux kernel, the following vulnerability has been resolved:\n\nnet: drv: netdevsim: don't napi_complete() from netpoll\n\nnetdevsim supports netpoll","summary":"In the Linux kernel, the following vulnerability has been resolved:\n\nnet: drv: netdevsim: don't napi_complete() from netpoll\n\nnetdevsim supports netpoll. Make sure we don't call napi_complete()\nfrom it, since it may not be scheduled. Bre…","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","vendor":"linux","product":"linux_kernel","affected":["linux_kernel >= 6.10, < 6.12.34","linux_kernel >= 6.13, < 6.15.3","linux_kernel = 6.16"],"patched":["linux_kernel 6.15.3"],"published":"2025-07-10","updated":"2026-10-15","sourceUpdated":"2026-10-15T22:18:37.560","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-38270","references":[{"url":"https://git.kernel.org/stable/c/1264971017b4d7141352a7fe29021bdfce5d885d","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/6837dd877270c57689bd866de9f3de14172c2439","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/a8ff2e362d901200a1075c3ca9c56d9c7bbef389","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"}],"tags":["nvd","cve.org"],"epss":0.00198,"epssPercentile":0.09541,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-10-15T21:49:13.510356Z"},"ingestedAt":"2026-10-15T22:48:25.502Z","slug":"CVE-2025-38270","body":"## Overview\n\nIn the Linux kernel, the following vulnerability has been resolved:\n\nnet: drv: netdevsim: don't napi_complete() from netpoll\n\nnetdevsim supports netpoll. Make sure we don't call napi_complete()\nfrom it, since it may not be scheduled. Breno reports hitting a\nwarning in napi_complete_done():\n\nWARNING: CPU: 14 PID: 104 at net/core/dev.c:6592 napi_complete_done+0x2cc/0x560\n  __napi_poll+0x2d8/0x3a0\n  handle_softirqs+0x1fe/0x710\n\nThis is presumably after netpoll stole the SCHED bit prematurely.\n\n## Affected\n\n- `linux_kernel >= 6.10, < 6.12.34`\n- `linux_kernel >= 6.13, < 6.15.3`\n- `linux_kernel = 6.16`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `linux_kernel 6.15.3`","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}