{"id":"CVE-2025-38574","title":"In the Linux kernel, the following vulnerability has been resolved:\n\npptp: ensure minimal skb length in pptp_xmit()\n\nCommit aabc6596ffb3 (\"net: ppp: Add bound checking for skb data\non ppp_sync_txmung\") fixed ppp_sync_txmunge()\n\nWe need a…","summary":"In the Linux kernel, the following vulnerability has been resolved:\n\npptp: ensure minimal skb length in pptp_xmit()\n\nCommit aabc6596ffb3 (\"net: ppp: Add bound checking for skb data\non ppp_sync_txmung\") fixed ppp_sync_txmunge()\n\nWe need a…","severity":"high","cvss":8.6,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H","cwe":["CWE-908"],"vendor":"linux","product":"linux_kernel","affected":["linux_kernel >= 2.6.13, < 5.4.297","linux_kernel >= 5.5, < 5.10.241","linux_kernel >= 5.11, < 5.15.190","linux_kernel >= 5.16, < 6.1.148","linux_kernel >= 6.2, < 6.6.102","linux_kernel >= 6.7, < 6.12.42","linux_kernel >= 6.13, < 6.15.10","linux_kernel >= 6.16, < 6.16.1","linux_kernel = 2.6.12","debian_linux = 11.0"],"patched":["linux_kernel 6.16.1"],"published":"2025-08-19","updated":"2026-10-15","sourceUpdated":"2026-10-15T22:18:45.977","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-38574","references":[{"url":"https://git.kernel.org/stable/c/1a04db0fd75cb6034fc27a56b67b3b8b9022a98c","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/26672f1679b143aa34fca0b6046b7fd0c184770d","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/5005d24377378a20e5c0e53052fc4ebdcdcbc611","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/504cc4ab91073d2ac7404ad146139f86ecee7193","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/5de7513f38f3c19c0610294ee478242bea356f8c","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/97b8c5d322c5c0038cac4bc56fdbe237d0be426f","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/b7dcda76fd0615c0599c89f36873a6cd48e02dbb","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/de9c4861fb42f0cd72da844c3c34f692d5895b7b","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/ea99b88b1999ebcb24d5d3a6b7910030f40d3bba","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html","label":"af854a3a-2127-422b-91ae-364da2661108"}],"tags":["nvd","cve.org"],"epss":0.00385,"epssPercentile":0.32355,"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-15T21:51:52.634407Z"},"ingestedAt":"2026-10-15T22:48:25.514Z","slug":"CVE-2025-38574","body":"## Overview\n\nIn the Linux kernel, the following vulnerability has been resolved:\n\npptp: ensure minimal skb length in pptp_xmit()\n\nCommit aabc6596ffb3 (\"net: ppp: Add bound checking for skb data\non ppp_sync_txmung\") fixed ppp_sync_txmunge()\n\nWe need a similar fix in pptp_xmit(), otherwise we might\nread uninit data as reported by syzbot.\n\nBUG: KMSAN: uninit-value in pptp_xmit+0xc34/0x2720 drivers/net/ppp/pptp.c:193\n  pptp_xmit+0xc34/0x2720 drivers/net/ppp/pptp.c:193\n  ppp_channel_bridge_input drivers/net/ppp/ppp_generic.c:2290 [inline]\n  ppp_input+0x1d6/0xe60 drivers/net/ppp/ppp_generic.c:2314\n  pppoe_rcv_core+0x1e8/0x760 drivers/net/ppp/pppoe.c:379\n  sk_backlog_rcv+0x142/0x420 include/net/sock.h:1148\n  __release_sock+0x1d3/0x330 net/core/sock.c:3213\n  release_sock+0x6b/0x270 net/core/sock.c:3767\n  pppoe_sendmsg+0x15d/0xcb0 drivers/net/ppp/pppoe.c:904\n  sock_sendmsg_nosec net/socket.c:712 [inline]\n  __sock_sendmsg+0x330/0x3d0 net/socket.c:727\n  ____sys_sendmsg+0x893/0xd80 net/socket.c:2566\n  ___sys_sendmsg+0x271/0x3b0 net/socket.c:2620\n  __sys_sendmmsg+0x2d9/0x7c0 net/socket.c:2709\n\n## Affected\n\n- `linux_kernel >= 2.6.13, < 5.4.297`\n- `linux_kernel >= 5.5, < 5.10.241`\n- `linux_kernel >= 5.11, < 5.15.190`\n- `linux_kernel >= 5.16, < 6.1.148`\n- `linux_kernel >= 6.2, < 6.6.102`\n- `linux_kernel >= 6.7, < 6.12.42`\n- `linux_kernel >= 6.13, < 6.15.10`\n- `linux_kernel >= 6.16, < 6.16.1`\n- `linux_kernel = 2.6.12`\n- `debian_linux = 11.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `linux_kernel 6.16.1`","depth":"twilight","depthScore":47,"depthScoreParts":{"impact":47.3,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}