{"id":"CVE-2025-53045","title":"Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB)","summary":"Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB).  Supported versions that are affected are 8.0.0-8.0.43, 8.4.0-8.4.6 and  9.0.0-9.4.0. Easily exploitable vulnerability allows high privileged attacker with ne…","severity":"medium","cvss":4.9,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","cwe":["CWE-400"],"vendor":"oracle","product":"mysql_server","affected":["mysql_server >= 8.0.0, <= 8.0.43","mysql_server >= 8.4.0, <= 8.4.6","mysql_server >= 9.0.0, <= 9.4.0"],"published":"2025-10-21","updated":"2026-10-08","sourceUpdated":"2026-10-08T11:10:00.250","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-53045","references":[{"url":"https://www.oracle.com/security-alerts/cpuoct2025.html","label":"secalert_us@oracle.com"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-53045.json"},{"url":"https://access.redhat.com/security/cve/CVE-2025-53045"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2405523"},{"url":"https://www.cve.org/CVERecord?id=CVE-2025-53045"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-53045"},{"url":"https://www.oracle.com/security-alerts/cpuoct2025.html#AppendixMSQL"},{"url":"https://access.redhat.com/errata/RHSA-2025:23008"},{"url":"https://access.redhat.com/errata/RHSA-2025:23134"},{"url":"https://access.redhat.com/errata/RHSA-2025:23137"},{"url":"https://access.redhat.com/errata/RHSA-2025:23111"},{"url":"https://access.redhat.com/errata/RHSA-2025:23109"}],"tags":["nvd","csaf","vex","red-hat"],"epss":0.0058,"epssPercentile":0.47483,"ingestedAt":"2026-10-08T11:31:27.461Z","patched":["enterprise_linux_appstream_v_10","enterprise_linux_appstream_v_8","enterprise_linux_appstream_v_9","enterprise_linux_codeready_linux_builder_v_10","enterprise_linux_codeready_linux_builder_v_9"],"slug":"CVE-2025-53045","body":"## Overview\n\nVulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB).  Supported versions that are affected are 8.0.0-8.0.43, 8.4.0-8.4.6 and  9.0.0-9.4.0. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server.  Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).\n\n## Affected\n\n- `mysql_server >= 8.0.0, <= 8.0.43`\n- `mysql_server >= 8.4.0, <= 8.4.6`\n- `mysql_server >= 9.0.0, <= 9.4.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Vendor advisories\n\n- **RHSA-2025:23008** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 10), Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) · released 2025-12-10 · [advisory](https://access.redhat.com/errata/RHSA-2025:23008)\n- **RHSA-2025:23134** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 8) · released 2025-12-11 · [advisory](https://access.redhat.com/errata/RHSA-2025:23134)\n- **RHSA-2025:23137** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 8) · released 2025-12-11 · [advisory](https://access.redhat.com/errata/RHSA-2025:23137)\n- **RHSA-2025:23111** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 9) · released 2025-12-11 · [advisory](https://access.redhat.com/errata/RHSA-2025:23111)\n- **RHSA-2025:23109** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 9), Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) · released 2025-12-11 · [advisory](https://access.redhat.com/errata/RHSA-2025:23109)","depth":"sunlit","depthScore":27,"depthScoreParts":{"impact":27,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}