{"id":"CVE-2025-58175","title":"GeoServer is an open source server that allows users to share and edit geospatial data","summary":"GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Re…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L","cwe":["CWE-20","CWE-611","CWE-918"],"vendor":"osgeo","product":"geoserver","affected":["geoserver < 2.26.4","geoserver >= 2.27.0, < 2.27.3"],"patched":["geoserver 2.27.3"],"published":"2026-06-18","updated":"2026-10-06","sourceUpdated":"2026-10-06T22:10:00.247","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-58175","references":[{"url":"https://github.com/geoserver/geoserver/pull/8622","label":"security-advisories@github.com"},{"url":"https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww","label":"security-advisories@github.com"},{"url":"https://osgeo-org.atlassian.net/browse/GEOS-11867","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-x4r9-gmw3-hxww"}],"tags":["nvd","ghsa","maven"],"epss":0.00287,"epssPercentile":0.21091,"aliases":["GHSA-x4r9-gmw3-hxww"],"ecosystem":"maven","ingestedAt":"2026-07-07T15:41:59.248Z","slug":"CVE-2025-58175","body":"## Overview\n\nGeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.\n\n## Affected\n\n- `geoserver < 2.26.4`\n- `geoserver >= 2.27.0, < 2.27.3`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `geoserver 2.27.3`\n\n## Package advisory (CVE-2025-58175)\n\nAffected packages:\n\n- `org.geoserver.web:gs-web-app <= 2.26.3`\n- `org.geoserver:gs-main <= 2.26.3`\n- `org.geoserver:gs-main >= 2.27.0, <= 2.27.2`\n- `org.geoserver.web:gs-web-app >= 2.27.0, <= 2.27.2`\n\nPatched in:\n\n- `org.geoserver.web:gs-web-app 2.26.4`\n- `org.geoserver:gs-main 2.26.4`\n- `org.geoserver:gs-main 2.27.3`\n- `org.geoserver.web:gs-web-app 2.27.3`\n\nSource: https://github.com/advisories/GHSA-x4r9-gmw3-hxww","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}