{"id":"CVE-2025-59940","title":"mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin","summary":"mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","cwe":["CWE-20"],"vendor":"Red Hat","product":"Multicluster Engine for Kubernetes","affected":["assisted_installer_for_red_hat_openshift_container_platform 2","multicluster_engine_for_kubernetes","openshift_container_platform 4"],"patched":["mkdocs-include-markdown-plugin 7.1.8"],"published":"2025-09-29","updated":"2026-10-09","sourceUpdated":"2026-10-09T09:10:00.213","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-59940","references":[{"url":"https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915","label":"security-advisories@github.com"},{"url":"https://github.com/mondeja/mkdocs-include-markdown-plugin/issues/274","label":"security-advisories@github.com"},{"url":"https://github.com/mondeja/mkdocs-include-markdown-plugin/pull/277","label":"security-advisories@github.com"},{"url":"https://github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9","label":"security-advisories@github.com"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59940.json"},{"url":"https://access.redhat.com/security/cve/CVE-2025-59940"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2400372"},{"url":"https://www.cve.org/CVERecord?id=CVE-2025-59940"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-59940"},{"url":"https://github.com/mondeja/mkdocs-include-markdown-plugin"}],"tags":["nvd","csaf","vex","red-hat","osv","pip"],"epss":0.00341,"epssPercentile":0.27468,"aliases":["GHSA-v39m-5m9j-m9w9","PYSEC-2026-1632"],"ecosystem":"pip","ingestedAt":"2026-07-08T18:25:53.057Z","slug":"CVE-2025-59940","body":"## Overview\n\nmkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2025-59940)\n\nAffected packages:\n\n- `mkdocs-include-markdown-plugin < 7.1.8`\n\nPatched in:\n\n- `mkdocs-include-markdown-plugin 7.1.8`\n\nSource: https://osv.dev/vulnerability/GHSA-v39m-5m9j-m9w9\n\n## Vendor advisories\n\n- **Red Hat VEX** · Moderate · affected: Assisted Installer for Red Hat OpenShift Container Platform 2, Multicluster Engine for Kubernetes, Red Hat OpenShift Container Platform 4 · no fix planned: Assisted Installer for Red Hat OpenShift Container Platform 2, Multicluster Engine for Kubernetes, Red Hat OpenShift Container Platform 4 · updated 2026-09-23 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-59940.json)","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}