{"id":"CVE-2025-61669","title":"Jupyter Server is the backend for Jupyter web applications","summary":"Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects …","severity":"medium","cvss":6.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","cwe":["CWE-601"],"vendor":"jupyter","product":"jupyter_server","affected":["jupyter_server < 2.18.0"],"patched":["jupyter_server 2.18.0"],"published":"2026-05-05","updated":"2026-10-07","sourceUpdated":"2026-10-07T09:10:00.160","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-61669","references":[{"url":"https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-qh7q-6qm3-653w","label":"security-advisories@github.com"},{"url":"https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-qh7q-6qm3-653w","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-61669"},{"url":"https://github.com/jupyter-server/jupyter_server"},{"url":"https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-server/PYSEC-2026-67.yaml"}],"tags":["nvd","osv","pip"],"epss":0.00244,"epssPercentile":0.15497,"aliases":["GHSA-qh7q-6qm3-653w","PYSEC-2026-67"],"ecosystem":"pip","ingestedAt":"2026-09-12T03:13:01.721Z","slug":"CVE-2025-61669","body":"## Overview\n\nJupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects to arbitrary external domains via values such as `///example.com`. An attacker can use a crafted login URL to redirect users to a malicious site and facilitate phishing attacks. This issue is fixed in version 2.18.0.\n\n## Affected\n\n- `jupyter_server < 2.18.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `jupyter_server 2.18.0`\n\n## Package advisory (CVE-2025-61669)\n\nAffected packages:\n\n- `jupyter-server < 2.18.0`\n\nPatched in:\n\n- `jupyter-server 2.18.0`\n\nSource: https://osv.dev/vulnerability/GHSA-qh7q-6qm3-653w","depth":"sunlit","depthScore":34,"depthScoreParts":{"impact":33.6,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":214055,"id":"CVE-2025-61669","ts":1790807348484,"field":"cvss","old":null,"new":"6.1"}]}