{"id":"CVE-2025-6196","title":"Libgepub: integer overflow in libgepub's epub archive handling","summary":"A flaw was found in libgepub, a library used to read EPUB files. The software mishandles file size calculations when opening specially crafted EPUB files, leading to incorrect memory allocations. This issue causes the application to cras…","severity":"medium","cvss":5.5,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","cvssSource":"cna","cwe":["CWE-190"],"vendor":"Red Hat","product":"libgepub","affected":["libgepub < 0.7.2","libgepub (all versions)"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2025-06-17T14:45:00.900554Z"},"published":"2025-06-17","updated":"2026-11-05","sourceUpdated":"2026-11-05T16:32:44.319Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2025-6196","references":[{"url":"https://access.redhat.com/security/cve/CVE-2025-6196"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2373117","label":"RHBZ#2373117"},{"url":"https://gitlab.gnome.org/GNOME/libgepub/-/issues/18"}],"tags":["cve.org"],"epss":0.00235,"epssPercentile":0.14576,"ingestedAt":"2026-11-05T22:38:31.363Z","slug":"CVE-2025-6196","body":"## Overview\n\nA flaw was found in libgepub, a library used to read EPUB files. The software mishandles file size calculations when opening specially crafted EPUB files, leading to incorrect memory allocations. This issue causes the application to crash. Known affected usage includes desktop services like Tumbler, which may process malicious files automatically when browsing directories. While no direct remote attack vectors are confirmed, any application using libgepub to parse user-supplied EPUB content could be vulnerable to a denial of service.\n\n## Affected\n\n- `libgepub < 0.7.2`\n- `libgepub (all versions)`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n### Workarounds\n\nMitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to a widespread installation base, or stability. It is strongly recommended to apply the upstream patch once available.","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":30.3,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}