{"id":"CVE-2025-62800","title":"FastMCP is the standard framework for building MCP applications","summary":"FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values ar…","severity":"medium","cvss":6.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","cwe":["CWE-79"],"vendor":"jlowin","product":"fastmcp","affected":["fastmcp < 2.13.0"],"patched":["fastmcp 2.13.0"],"published":"2025-10-28","updated":"2026-10-08","sourceUpdated":"2026-10-08T11:10:00.250","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-62800","references":[{"url":"https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc","label":"security-advisories@github.com"},{"url":"https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-62800"},{"url":"https://github.com/jlowin/fastmcp/pull/2090"},{"url":"https://github.com/jlowin/fastmcp/commit/2a20f54617a37213ed83894a8c2f0ac38a2e83a3"},{"url":"https://github.com/jlowin/fastmcp"}],"tags":["nvd","osv","pip"],"epss":0.00276,"epssPercentile":0.19938,"aliases":["GHSA-mxxr-jv3v-6pgc","PYSEC-2026-1364"],"ecosystem":"pip","ingestedAt":"2026-07-08T18:25:51.476Z","slug":"CVE-2025-62800","body":"## Overview\n\nFastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.\n\n## Affected\n\n- `fastmcp < 2.13.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `fastmcp 2.13.0`\n\n## Package advisory (CVE-2025-62800)\n\nAffected packages:\n\n- `fastmcp < 2.13.0`\n\nPatched in:\n\n- `fastmcp 2.13.0`\n\nSource: https://osv.dev/vulnerability/GHSA-mxxr-jv3v-6pgc","depth":"sunlit","depthScore":34,"depthScoreParts":{"impact":33.6,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":217959,"id":"CVE-2025-62800","ts":1791459536592,"field":"cvss","old":null,"new":"6.1"}]}