{"id":"CVE-2025-66335","title":"Apache Doris MCP Server versions earlier than 0.6.1 are affected by an improper neutralization flaw in query context handling that may allow execution of unintended SQL statements and bypass of intended query validation and access restri…","summary":"Apache Doris MCP Server versions earlier than 0.6.1 are affected by an improper neutralization flaw in query context handling that may allow execution of unintended SQL statements and bypass of intended query validation and access restri…","severity":"medium","cvss":5.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","cwe":["CWE-89"],"vendor":"apache","product":"doris_mcp_server","affected":["doris_mcp_server >= 0.1.0, < 0.6.1"],"patched":["doris_mcp_server 0.6.1"],"published":"2026-04-20","updated":"2026-10-07","sourceUpdated":"2026-10-07T09:10:00.160","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-66335","references":[{"url":"https://lists.apache.org/thread/odp0fyyst8kxm7hhm9z4d1snh1y4hjpy","label":"security@apache.org"},{"url":"http://www.openwall.com/lists/oss-security/2026/04/17/4","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-66335"},{"url":"https://github.com/apache/doris-mcp-server"},{"url":"https://github.com/apache/doris-mcp-server/releases/tag/0.6.1"}],"tags":["nvd","osv","pip"],"epss":0.00655,"epssPercentile":0.51169,"aliases":["GHSA-qhfq-gvvc-5q6q","PYSEC-2026-2459"],"ecosystem":"pip","ingestedAt":"2026-07-13T18:58:02.012Z","slug":"CVE-2025-66335","body":"## Overview\n\nApache Doris MCP Server versions earlier than 0.6.1 are affected by an improper neutralization flaw in query context handling that may allow execution of unintended SQL statements and bypass of intended query validation and access restrictions through the MCP query execution interface. Version 0.6.1 and later are not affected.\n\n## Affected\n\n- `doris_mcp_server >= 0.1.0, < 0.6.1`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `doris_mcp_server 0.6.1`\n\n## Package advisory (CVE-2025-66335)\n\nAffected packages:\n\n- `doris-mcp-server >= 0.1.0, < 0.6.1`\n\nPatched in:\n\n- `doris-mcp-server 0.6.1`\n\nSource: https://osv.dev/vulnerability/GHSA-qhfq-gvvc-5q6q","depth":"sunlit","depthScore":29,"depthScoreParts":{"impact":29.2,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}