{"id":"CVE-2025-67735","title":"Netty is an asynchronous, event-driven network application framework","summary":"Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a …","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","cwe":["CWE-93"],"vendor":"netty","product":"netty","affected":["netty < 4.1.129","netty >= 4.2.0, < 4.2.8"],"patched":["netty 4.2.8"],"published":"2025-12-16","updated":"2026-10-14","sourceUpdated":"2026-10-14T13:10:00.187","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-67735","references":[{"url":"https://github.com/netty/netty/security/advisories/GHSA-84h7-rjj3-6jx4","label":"security-advisories@github.com"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-67735.json"},{"url":"https://access.redhat.com/security/cve/CVE-2025-67735"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2422568"},{"url":"https://www.cve.org/CVERecord?id=CVE-2025-67735"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-67735"},{"url":"https://access.redhat.com/errata/RHSA-2026:1899"},{"url":"https://access.redhat.com/errata/RHSA-2026:1965"}],"tags":["nvd","csaf","vex","red-hat"],"epss":0.0032,"epssPercentile":0.24885,"ingestedAt":"2026-10-14T13:30:58.435Z","slug":"CVE-2025-67735","body":"## Overview\n\nNetty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.\n\n## Affected\n\n- `netty < 4.1.129`\n- `netty >= 4.2.0, < 4.2.8`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `netty 4.2.8`\n\n## Vendor advisories\n\n- **RHSA-2026:1899** · Red Hat · fixed in: Red Hat build of Quarkus 3.20.5.redhat · released 2026-02-05 · [advisory](https://access.redhat.com/errata/RHSA-2026:1899)\n- **RHSA-2026:1965** · Red Hat · fixed in: Red Hat build of Quarkus 3.27.2.redhat · released 2026-02-05 · [advisory](https://access.redhat.com/errata/RHSA-2026:1965)\n- **Red Hat VEX** · Moderate · affected: Cryostat 4, Logging Subsystem for Red Hat OpenShift, OpenShift Serverless, Red Hat AMQ Broker 7, Red Hat AMQ Clients, Red Hat build of Apache Camel - HawtIO 4, … · no fix planned: Cryostat 4, Logging Subsystem for Red Hat OpenShift, OpenShift Serverless, Red Hat AMQ Broker 7, … · updated 2026-10-20 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-67735.json)","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}