{"id":"CVE-2025-68725","title":"In the Linux kernel, the following vulnerability has been resolved:\n\nbpf: Do not let BPF test infra emit invalid GSO types to stack\n\nYinhao et al","summary":"In the Linux kernel, the following vulnerability has been resolved:\n\nbpf: Do not let BPF test infra emit invalid GSO types to stack\n\nYinhao et al. reported that their fuzzer tool was able to trigger a\nskb_warn_bad_offload() from netif_sk…","severity":"medium","cvss":5.5,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","vendor":"linux","product":"linux_kernel","affected":["linux_kernel >= 5.6, < 5.10.249","linux_kernel >= 5.11, < 5.15.199","linux_kernel >= 5.16, < 6.1.162","linux_kernel >= 6.2, < 6.6.122","linux_kernel >= 6.7, < 6.12.68","linux_kernel >= 6.13, < 6.18.2"],"patched":["linux_kernel 6.18.2"],"published":"2025-12-24","updated":"2026-10-15","sourceUpdated":"2026-10-15T02:18:12.640","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-68725","references":[{"url":"https://git.kernel.org/stable/c/04a899573fb87273a656f178b5f920c505f68875","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/0f3a60869ca22024dfb9c6fce412b0c70cb4ea36","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/768376ece7036ecb8604961793a1b72afe6345dd","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/8670b53b8ee91f028f7240531064020b7413c461","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/bb7902ed7d7f6d6a7c6c4dc25410d6127ce1085f","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/e0ffb64a2d72c6705b4a4c9efef600409f7e98a0","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://git.kernel.org/stable/c/fbea4c63b5385588cb44ab21f91e55e33c719a54","label":"416baaa9-dc9f-4396-8d5f-8c081fb06d67"},{"url":"https://cert-portal.siemens.com/productcert/html/ssa-019113.html","label":"0b142b55-0307-4c5a-b3c9-f314f3fb7c5e"},{"url":"https://cert-portal.siemens.com/productcert/html/ssa-457936.html","label":"0b142b55-0307-4c5a-b3c9-f314f3fb7c5e"}],"tags":["nvd","cve.org"],"epss":0.00185,"epssPercentile":0.07984,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-06-10T20:40:17.204014Z"},"ingestedAt":"2026-09-08T15:33:26.995Z","slug":"CVE-2025-68725","body":"## Overview\n\nIn the Linux kernel, the following vulnerability has been resolved:\n\nbpf: Do not let BPF test infra emit invalid GSO types to stack\n\nYinhao et al. reported that their fuzzer tool was able to trigger a\nskb_warn_bad_offload() from netif_skb_features() -> gso_features_check().\nWhen a BPF program - triggered via BPF test infra - pushes the packet\nto the loopback device via bpf_clone_redirect() then mentioned offload\nwarning can be seen. GSO-related features are then rightfully disabled.\n\nWe get into this situation due to convert___skb_to_skb() setting\ngso_segs and gso_size but not gso_type. Technically, it makes sense\nthat this warning triggers since the GSO properties are malformed due\nto the gso_type. Potentially, the gso_type could be marked non-trustworthy\nthrough setting it at least to SKB_GSO_DODGY without any other specific\nassumptions, but that also feels wrong given we should not go further\ninto the GSO engine in the first place.\n\nThe checks were added in 121d57af308d (\"gso: validate gso_type in GSO\nhandlers\") because there were malicious (syzbot) senders that combine\na protocol with a non-matching gso_type. If we would want to drop such\npackets, gso_features_check() currently only returns feature flags via\nnetif_skb_features(), so one location for potentially dropping such skbs\ncould be validate_xmit_unreadable_skb(), but then otoh it would be\nan additional check in the fast-path for a very corner case. Given\nbpf_clone_redirect() is the only place where BPF test infra could emit\nsuch packets, lets reject them right there.\n\n## Affected\n\n- `linux_kernel >= 5.6, < 5.10.249`\n- `linux_kernel >= 5.11, < 5.15.199`\n- `linux_kernel >= 5.16, < 6.1.162`\n- `linux_kernel >= 6.2, < 6.6.122`\n- `linux_kernel >= 6.7, < 6.12.68`\n- `linux_kernel >= 6.13, < 6.18.2`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `linux_kernel 6.18.2`","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":30.3,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":219645,"id":"CVE-2025-68725","ts":1791890708843,"field":"cvss","old":null,"new":"5.5"},{"seq":219644,"id":"CVE-2025-68725","ts":1791890708843,"field":"severity","old":"none","new":"medium"}]}