{"id":"CVE-2025-71332","title":"Flowise through 2.2.7 contains a SQL injection vulnerability in the importChatflows API","summary":"Flowise through 2.2.7 contains a SQL injection vulnerability in the importChatflows API. Due to insufficient validation of the chatflow.id value, an authenticated user can supply a crafted JSON import file whose id field is concatenated …","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N","cwe":["CWE-89","CWE-564"],"vendor":"flowiseai","product":"flowise","affected":["flowise <= 2.2.7"],"published":"2026-06-24","updated":"2026-10-12","sourceUpdated":"2026-10-12T21:10:00.227","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2025-71332","references":[{"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9c4c-g95m-c8cp","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/flowise-sql-injection-in-importchatflows-api-via-chatflow-id-parameter","label":"disclosure@vulncheck.com"},{"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9c4c-g95m-c8cp","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://github.com/FlowiseAI/Flowise/pull/4226"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-71332"},{"url":"https://github.com/advisories/GHSA-9c4c-g95m-c8cp"}],"tags":["nvd","ghsa","npm"],"epss":0.00516,"epssPercentile":0.43741,"ingestedAt":"2026-09-30T17:13:20.774Z","aliases":["GHSA-9c4c-g95m-c8cp"],"ecosystem":"npm","scores":{"nvd":6.5,"ghsa":5.9},"slug":"CVE-2025-71332","body":"## Overview\n\nFlowise through 2.2.7 contains a SQL injection vulnerability in the importChatflows API. Due to insufficient validation of the chatflow.id value, an authenticated user can supply a crafted JSON import file whose id field is concatenated unsanitized into a SQL IN clause, allowing arbitrary SQL to be executed, including blind and error-based extraction of data from the credential table.\n\n## Affected\n\n- `flowise <= 2.2.7`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2025-71332)\n\nAffected packages:\n\n- `flowise <= 2.2.7`\n\nSource: https://github.com/advisories/GHSA-9c4c-g95m-c8cp","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}