{"id":"CVE-2026-100310","title":"GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks","summary":"GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a dir…","severity":"high","cvss":7,"cvssVector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-426"],"vendor":"GNU","product":"libextractor","affected":["libextractor < 1.16"],"published":"2026-09-25","updated":"2026-09-30","sourceUpdated":"2026-09-30T17:31:44.573","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-100310","references":[{"url":"https://ftp.gnu.org/gnu/libextractor/","label":"disclosure@vulncheck.com"},{"url":"https://git.gnunet.org/gnunet/libextractor/commit/6edfa653c048800e24a17f7e8cc2bb42659b8d01.html","label":"disclosure@vulncheck.com"},{"url":"https://github.com/Haitam-lazaar/libextractor-privesc","label":"disclosure@vulncheck.com"},{"url":"https://www.gnu.org/software/libextractor/","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/gnu-libextractor-before-1.16-privilege-escalation-via-libextractor-prefix","label":"disclosure@vulncheck.com"},{"url":"http://www.openwall.com/lists/oss-security/2026/09/25/25","label":"af854a3a-2127-422b-91ae-364da2661108"}],"tags":["nvd","cve.org","exploit-available"],"epss":0.00137,"epssPercentile":0.0305,"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-09-30T00:05:41.549904Z"},"ingestedAt":"2026-09-25T20:17:49.417Z","slug":"CVE-2026-100310","body":"## Overview\n\nGNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"midnight","depthScore":51,"depthScoreParts":{"impact":38.5,"likelihood":0,"exploitation":12,"ransomware":0},"changes":[{"seq":213234,"id":"CVE-2026-100310","ts":1790729674841,"field":"exploit_available","old":"false","new":"true"}]}