{"id":"CVE-2026-100840","title":"MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval()","summary":"MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attack…","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","cwe":["CWE-95"],"vendor":"project-monai","product":"monai","affected":["monai <= 1.6.0"],"published":"2026-09-27","updated":"2026-09-30","sourceUpdated":"2026-09-30T15:40:44.640","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-100840","references":[{"url":"https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-873f-pvrv-4x83","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/monai-through-1.6.0-remote-code-execution-via-bundle-configuration","label":"disclosure@vulncheck.com"},{"url":"https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-873f-pvrv-4x83","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"tags":["nvd","cve.org","exploit-available","osv","pip"],"epss":0.00313,"epssPercentile":0.24008,"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-09-28T16:44:24.110450Z"},"ingestedAt":"2026-09-27T02:41:45.572Z","aliases":["PYSEC-2026-4015","GHSA-873f-pvrv-4x83"],"ecosystem":"pip","patched":["monai 1.6.1rc0"],"slug":"CVE-2026-100840","body":"## Overview\n\nMONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().\n\n## Affected\n\n- `monai <= 1.6.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-100840)\n\nAffected packages:\n\n- `monai < 1.6.1rc0`\n\nPatched in:\n\n- `monai 1.6.1rc0`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-4015","depth":"midnight","depthScore":55,"depthScoreParts":{"impact":42.9,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":212045,"id":"CVE-2026-100840","ts":1790615858715,"field":"exploit_available","old":"false","new":"true"}]}