{"id":"CVE-2026-101288","title":"Langflow OSS is affected by multiple vulnerabilities","summary":"IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-94"],"vendor":"IBM","product":"Langflow OSS","affected":["langflow_oss >= 1.0.0 <= 1.12.3"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-10-30T03:56:30.294890Z"},"published":"2026-10-29","updated":"2026-10-30","sourceUpdated":"2026-10-30T17:18:26.636Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-101288","references":[{"url":"https://www.ibm.com/support/pages/node/7293015"}],"tags":["cve.org"],"epss":0.00702,"epssPercentile":0.53365,"ingestedAt":"2026-11-05T16:24:31.182Z","slug":"CVE-2026-101288","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.\n\n## Affected\n\n- `langflow_oss >= 1.0.0 <= 1.12.3`\n\n## Remediation\n\nIBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ \n\n\n\nFor Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.","depth":"twilight","depthScore":49,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}