{"id":"CVE-2026-101331","title":"IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to obtain sensitive information due to insufficiently protected credentials.","summary":"IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to obtain sensitive information due to insufficiently protected credentials.","severity":"high","cvss":7.7,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","cwe":["CWE-522"],"vendor":"langflow","product":"langflow","affected":["langflow >= 1.0.0, < 1.12.3"],"patched":["langflow 1.12.3"],"published":"2026-10-07","updated":"2026-10-08","sourceUpdated":"2026-10-08T18:16:35.340","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-101331","references":[{"url":"https://www.ibm.com/support/pages/node/7290694","label":"psirt@us.ibm.com"}],"tags":["nvd","cve.org"],"epss":0.00286,"epssPercentile":0.21045,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-07T16:18:06.648613Z"},"ingestedAt":"2026-10-07T01:27:17.509Z","slug":"CVE-2026-101331","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to obtain sensitive information due to insufficiently protected credentials.\n\n## Affected\n\n- `langflow >= 1.0.0, < 1.12.3`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `langflow 1.12.3`","depth":"twilight","depthScore":42,"depthScoreParts":{"impact":42.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}