{"id":"CVE-2026-103370","title":"Awesome Support <= 6.4.1 - Authenticated (Custom+) Stored Cross-Site Scripting via Ticket Attachment MIME Confusion","summary":"The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpas_files' parameter in all versions up to, and including, 6.4.1 due to insufficient input sanitization…","severity":"medium","cvss":6.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-79"],"vendor":"awesomesupport","product":"Awesome Support – WordPress HelpDesk & Support Plugin","affected":["awesome_support_wordpress_helpdesk_support_plugin <= 6.4.1"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-29T01:35:25.970203Z"},"published":"2026-10-28","updated":"2026-10-29","sourceUpdated":"2026-10-29T01:41:54.736Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-103370","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/01515533-197c-41c0-9c2b-6f0317cdc375?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/awesome-support/tags/6.4.1/includes/file-uploader/class-file-uploader.php#L669"},{"url":"https://plugins.trac.wordpress.org/browser/awesome-support/tags/6.4.1/includes/file-uploader/class-file-uploader.php#L2032"},{"url":"https://plugins.trac.wordpress.org/browser/awesome-support/tags/6.4.1/includes/file-uploader/class-file-uploader.php#L2195"},{"url":"https://wordpress.org/plugins/awesome-support/"},{"url":"https://plugins.trac.wordpress.org/changeset/3749553/awesome-support/trunk/includes/file-uploader/class-file-uploader.php"}],"tags":["cve.org"],"epss":0.00256,"epssPercentile":0.17249,"ingestedAt":"2026-10-28T07:06:27.130Z","slug":"CVE-2026-103370","body":"## Overview\n\nThe Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpas_files' parameter in all versions up to, and including, 6.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the \"Enable drag-n-drop uploader for ticket form\" setting is enabled, as it is disabled by default.\n\n## Affected\n\n- `awesome_support_wordpress_helpdesk_support_plugin <= 6.4.1`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":35,"depthScoreParts":{"impact":35.2,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}