{"id":"CVE-2026-104309","title":"Langflow OSS is affected by multiple vulnerabilities","summary":"IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory.","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","cvssSource":"cna","cwe":["CWE-22"],"vendor":"IBM","product":"Langflow OSS","affected":["langflow_oss >= 1.0.0 <= 1.12.3"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-29T19:37:09.999017Z"},"published":"2026-10-29","updated":"2026-10-29","sourceUpdated":"2026-10-29T19:37:22.227Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-104309","references":[{"url":"https://www.ibm.com/support/pages/node/7293015"}],"tags":["cve.org"],"epss":0.00599,"epssPercentile":0.48693,"ingestedAt":"2026-11-01T23:03:55.468Z","slug":"CVE-2026-104309","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory.\n\n## Affected\n\n- `langflow_oss >= 1.0.0 <= 1.12.3`\n\n## Remediation\n\nIBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ \n\n\n\nFor Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}