{"id":"CVE-2026-104331","title":"Langflow OSS is affected by multiple vulnerabilities","summary":"IBM Langflow OSS 1.0.0 through 1.12.3 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating…","severity":"medium","cvss":5.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-918"],"vendor":"IBM","product":"Langflow OSS","affected":["langflow_oss >= 1.0.0 <= 1.12.3"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-04T01:20:58.074004Z"},"published":"2026-10-29","updated":"2026-11-04","sourceUpdated":"2026-11-04T01:21:24.499Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-104331","references":[{"url":"https://www.ibm.com/support/pages/node/7293015"}],"tags":["cve.org"],"epss":0.0018,"epssPercentile":0.07584,"ingestedAt":"2026-11-01T20:00:16.955Z","slug":"CVE-2026-104331","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.12.3 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks.\n\n## Affected\n\n- `langflow_oss >= 1.0.0 <= 1.12.3`\n\n## Remediation\n\nIBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ \n\n\n\nFor Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":29.7,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}