{"id":"CVE-2026-104714","title":"Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts","summary":"Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts. Where a localized message formats a date or time argument, the formatter retained for that message by the applica…","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-362"],"vendor":"apache","product":"struts","affected":["struts >= 2.0.0, <= 2.3.37","struts >= 2.5.0, <= 2.5.33","struts >= 6.0.0, < 6.12.0","struts >= 7.0.0, < 7.4.0"],"patched":["struts 7.4.0"],"published":"2026-10-05","updated":"2026-10-08","sourceUpdated":"2026-10-08T19:16:14.527","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-104714","references":[{"url":"https://cwiki.apache.org/confluence/display/WW/S2-078","label":"security@apache.org"},{"url":"http://www.openwall.com/lists/oss-security/2026/10/05/13","label":"af854a3a-2127-422b-91ae-364da2661108"}],"tags":["nvd","cve.org"],"epss":0.00527,"epssPercentile":0.44432,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-10-06T14:13:22.832050Z"},"ingestedAt":"2026-10-05T19:30:59.978Z","slug":"CVE-2026-104714","body":"## Overview\n\nConcurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts. Where a localized message formats a date or time argument, the formatter retained for that message by the application-wide text provider is used by concurrently served requests without isolation, so a value belonging to one user can appear in another user's response, or the rendering can fail and surface as a server error. Applications whose localized messages format no date or time arguments are not affected.\n\nThis issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.\n\nUsers are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.\n\n## Affected\n\n- `struts >= 2.0.0, <= 2.3.37`\n- `struts >= 2.5.0, <= 2.5.33`\n- `struts >= 6.0.0, < 6.12.0`\n- `struts >= 7.0.0, < 7.4.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `struts 7.4.0`","depth":"twilight","depthScore":49,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":216491,"id":"CVE-2026-104714","ts":1791298974085,"field":"cvss","old":null,"new":"8.8"},{"seq":216490,"id":"CVE-2026-104714","ts":1791298974085,"field":"severity","old":"none","new":"high"}]}