{"id":"CVE-2026-105847","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, a user who can query a collection with a polymorphic join to sensitive fields can infe…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","cwe":["CWE-200","CWE-639"],"vendor":"payloadcms","product":"payload","affected":["payload >= 3.0.0, < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:13:38.000","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105847","references":[{"url":"https://github.com/payloadcms/payload/commit/caa3f69b5aecc6e7c2b459ed87972cbca9f33ee5","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-fpww-c55p-cjv6","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-fpww-c55p-cjv6"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00244,"epssPercentile":0.15511,"aliases":["GHSA-fpww-c55p-cjv6"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-06T17:22:09.250635Z"},"scores":{"nvd":6.5,"cna":7.1},"ingestedAt":"2026-10-06T17:09:22.185Z","slug":"CVE-2026-105847","body":"## Overview\n\nPayload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, a user who can query a collection with a polymorphic join to sensitive fields can infer hidden or read-restricted values, including password-reset tokens, through polymorphic join filters. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload >= 3.0.0, < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105847)\n\nAffected packages:\n\n- `payload >= 3.0.0, < 3.90.0`\n- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `payload 3.90.0`\n- `payload 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-fpww-c55p-cjv6","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":220648,"id":"CVE-2026-105847","ts":1792026526565,"field":"cvss","old":"7.1","new":"6.5"},{"seq":220647,"id":"CVE-2026-105847","ts":1792026526565,"field":"severity","old":"high","new":"medium"}]}