{"id":"CVE-2026-105850","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmat…","severity":"high","cvss":8.2,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L","cwe":["CWE-837"],"vendor":"payloadcms","product":"payload","affected":["payload < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:12:52.177","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105850","references":[{"url":"https://github.com/payloadcms/payload/commit/6c0c4dc9b4ce1ac87b03fbb5dd7356b8559cbc4e","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-8r29-2mp2-pmrw","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-8r29-2mp2-pmrw"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00308,"epssPercentile":0.23525,"aliases":["GHSA-8r29-2mp2-pmrw"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-06T16:28:14.279337Z"},"scores":{"nvd":8.2,"cna":8.8},"ingestedAt":"2026-10-06T17:09:22.183Z","slug":"CVE-2026-105850","body":"## Overview\n\nPayload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmation to be processed more than once under certain conditions. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105850)\n\nAffected packages:\n\n- `@payloadcms/plugin-ecommerce < 3.90.0`\n- `@payloadcms/plugin-ecommerce >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `@payloadcms/plugin-ecommerce 3.90.0`\n- `@payloadcms/plugin-ecommerce 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-8r29-2mp2-pmrw","depth":"twilight","depthScore":45,"depthScoreParts":{"impact":45.1,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":220652,"id":"CVE-2026-105850","ts":1792026527512,"field":"cvss","old":"8.8","new":"8.2"}]}