{"id":"CVE-2026-105851","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, the duplicate operation copies values from a source document even when a field is hidd…","severity":"high","cvss":8.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","cwe":["CWE-284","CWE-863"],"vendor":"payloadcms","product":"payload","affected":["payload >= 3.0.0, < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:12:41.997","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105851","references":[{"url":"https://github.com/payloadcms/payload/commit/099ef12e2682f076aa8e8d0ccb790536b4e1027f","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-vc4h-q48j-5hcx","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-vc4h-q48j-5hcx"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00249,"epssPercentile":0.16174,"aliases":["GHSA-vc4h-q48j-5hcx"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-06T17:34:36.004571Z"},"scores":{"nvd":8.1,"cna":9.3},"ingestedAt":"2026-10-06T17:09:22.184Z","slug":"CVE-2026-105851","body":"## Overview\n\nPayload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, the duplicate operation copies values from a source document even when a field is hidden or its access.read or access.create rule rejects that value for the caller. The disableDuplicate setting does not prevent this access-control bypass. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload >= 3.0.0, < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105851)\n\nAffected packages:\n\n- `payload > 3.0.0, < 3.90.0`\n- `payload > 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `payload 3.90.0`\n- `payload 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-vc4h-q48j-5hcx","depth":"twilight","depthScore":45,"depthScoreParts":{"impact":44.6,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":220654,"id":"CVE-2026-105851","ts":1792026527823,"field":"cvss","old":"9.3","new":"8.1"},{"seq":220653,"id":"CVE-2026-105851","ts":1792026527823,"field":"severity","old":"critical","new":"high"}]}