{"id":"CVE-2026-105852","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, querying a readable collection with a relationship to another collection can expose information a…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","cwe":["CWE-862"],"vendor":"payloadcms","product":"payload","affected":["payload < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:12:33.800","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105852","references":[{"url":"https://github.com/payloadcms/payload/commit/94059cf4bc6170ce88453015c0c6551329ae3982","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-7c34-32v3-j575","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-7c34-32v3-j575"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00268,"epssPercentile":0.18829,"aliases":["GHSA-7c34-32v3-j575"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-06T17:22:37.286471Z"},"scores":{"nvd":7.5,"cna":6.9},"ingestedAt":"2026-10-06T17:09:22.183Z","slug":"CVE-2026-105852","body":"## Overview\n\nPayload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, querying a readable collection with a relationship to another collection can expose information about related documents protected by access.read where constraints. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105852)\n\nAffected packages:\n\n- `payload < 3.90.0`\n- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `payload 3.90.0`\n- `payload 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-7c34-32v3-j575","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":41.3,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":220656,"id":"CVE-2026-105852","ts":1792026528137,"field":"cvss","old":"6.9","new":"7.5"},{"seq":220655,"id":"CVE-2026-105852","ts":1792026528137,"field":"severity","old":"medium","new":"high"}]}