{"id":"CVE-2026-105854","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, a malformed multipart request body can cause multipart Content-Type processing to take…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cwe":["CWE-400","CWE-1333"],"vendor":"payloadcms","product":"payload","affected":["payload >= 3.0.0, < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:12:03.407","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105854","references":[{"url":"https://github.com/payloadcms/payload/commit/0084bd51fb7742b26a88431bb84cb1696857e6dc","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-2g7p-5934-q4w7","label":"security-advisories@github.com"},{"url":"https://github.com/advisories/GHSA-2g7p-5934-q4w7"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00354,"epssPercentile":0.28875,"aliases":["GHSA-2g7p-5934-q4w7"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-06T17:29:52.942510Z"},"scores":{"nvd":7.5,"cna":8.7},"ingestedAt":"2026-10-06T17:09:22.182Z","slug":"CVE-2026-105854","body":"## Overview\n\nPayload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, a malformed multipart request body can cause multipart Content-Type processing to take an extremely long time, resulting in uncontrolled resource consumption. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload >= 3.0.0, < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105854)\n\nAffected packages:\n\n- `payload >= 3.0.0, < 3.90.0`\n- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `payload 3.90.0`\n- `payload 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-2g7p-5934-q4w7","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":41.3,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":220659,"id":"CVE-2026-105854","ts":1792026528762,"field":"cvss","old":"8.7","new":"7.5"}]}