{"id":"CVE-2026-105859","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can submit a request to a specific update endpoint that modifies collection documents…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-639","CWE-862"],"vendor":"payloadcms","product":"payload","affected":["payload < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:10:48.717","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105859","references":[{"url":"https://github.com/payloadcms/payload/commit/36fa9af73dd04fa59f4b4a06d11454538c4c1409","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-f7hx-52q9-hcrf","label":"security-advisories@github.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-105859"},{"url":"https://github.com/advisories/GHSA-f7hx-52q9-hcrf"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00347,"epssPercentile":0.28072,"aliases":["GHSA-f7hx-52q9-hcrf"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"total","timestamp":"2026-10-06T17:37:15.906390Z"},"ingestedAt":"2026-10-06T17:09:22.197Z","slug":"CVE-2026-105859","body":"## Overview\n\nPayload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can submit a request to a specific update endpoint that modifies collection documents without enforcing collection or field-level access control when orderable is enabled on a collection or join field. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105859)\n\nAffected packages:\n\n- `payload < 3.90.0`\n- `payload >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `payload 3.90.0`\n- `payload 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-f7hx-52q9-hcrf","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}