{"id":"CVE-2026-105867","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In @payloadcms/storage-s3 versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user can overwrite an existing S3 object belonging to ano…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","cwe":["CWE-639"],"vendor":"payloadcms","product":"payload","affected":["payload < 3.90.0","payload = 4.0.0"],"patched":["payload 3.90.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:07:52.077","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-105867","references":[{"url":"https://github.com/payloadcms/payload/commit/2df8238fbf17edfce335c399b90bf524ba9906a2","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.90.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-7vg8-29qx-jgj8","label":"security-advisories@github.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-105867"},{"url":"https://github.com/advisories/GHSA-7vg8-29qx-jgj8"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.0022,"epssPercentile":0.12475,"aliases":["GHSA-7vg8-29qx-jgj8"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-06T17:24:30.442506Z"},"scores":{"nvd":6.5,"cna":7.1},"ingestedAt":"2026-10-06T17:09:22.189Z","slug":"CVE-2026-105867","body":"## Overview\n\nPayload is a free and open source headless content management system. In @payloadcms/storage-s3 versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user can overwrite an existing S3 object belonging to another upload collection when client uploads are enabled for multiple collections sharing a bucket and useCompositePrefixes is false or unset. This bypasses the target collection's access controls and prior file validation. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.\n\n## Affected\n\n- `payload < 3.90.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.90.0`\n\n## Package advisory (CVE-2026-105867)\n\nAffected packages:\n\n- `@payloadcms/storage-s3 < 3.90.0`\n- `@payloadcms/storage-s3 >= 4.0.0-canary.0, < 4.0.0-canary.34`\n\nPatched in:\n\n- `@payloadcms/storage-s3 3.90.0`\n- `@payloadcms/storage-s3 4.0.0-canary.34`\n\nSource: https://github.com/advisories/GHSA-7vg8-29qx-jgj8","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":220668,"id":"CVE-2026-105867","ts":1792026532820,"field":"cvss","old":"7.1","new":"6.5"},{"seq":220667,"id":"CVE-2026-105867","ts":1792026532820,"field":"severity","old":"high","new":"medium"}]}