{"id":"CVE-2026-106100","title":"Payload is a free and open source headless content management system","summary":"Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that fie…","severity":"high","cvss":7.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N","cwe":["CWE-639","CWE-915"],"vendor":"payloadcms","product":"payload","affected":["payload < 3.87.0","payload = 4.0.0"],"patched":["payload 3.87.0"],"published":"2026-10-06","updated":"2026-10-15","sourceUpdated":"2026-10-15T00:07:39.960","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-106100","references":[{"url":"https://github.com/payloadcms/payload/commit/2a69863deb0e3c87e36c1b3b17ab2d5b02fcb941","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/commit/8f77dffa9552885ec2710768cfee15b57e389935","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/releases/tag/v3.87.0","label":"security-advisories@github.com"},{"url":"https://github.com/payloadcms/payload/security/advisories/GHSA-4ww4-68q3-h7g5","label":"security-advisories@github.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-106100"},{"url":"https://github.com/advisories/GHSA-4ww4-68q3-h7g5"}],"tags":["nvd","cve.org","ghsa","npm"],"epss":0.00216,"epssPercentile":0.11892,"aliases":["GHSA-4ww4-68q3-h7g5"],"ecosystem":"npm","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-06T17:28:47.529744Z"},"ingestedAt":"2026-10-06T17:09:22.186Z","slug":"CVE-2026-106100","body":"## Overview\n\nPayload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.\n\n## Affected\n\n- `payload < 3.87.0`\n- `payload = 4.0.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `payload 3.87.0`\n\n## Package advisory (CVE-2026-106100)\n\nAffected packages:\n\n- `@payloadcms/db-mongodb < 3.87.0`\n- `@payloadcms/db-mongodb >= 4.0.0-canary.0, < 4.0.0-canary.20`\n\nPatched in:\n\n- `@payloadcms/db-mongodb 3.87.0`\n- `@payloadcms/db-mongodb 4.0.0-canary.20`\n\nSource: https://github.com/advisories/GHSA-4ww4-68q3-h7g5","depth":"twilight","depthScore":39,"depthScoreParts":{"impact":39.1,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}