{"id":"CVE-2026-110193","title":"Langflow OSS is affected by multiple vulnerabilities","summary":"IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary op…","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-94"],"vendor":"IBM","product":"Langflow OSS","affected":["langflow_oss >= 1.0.0 <= 1.12.8"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-10-29T00:00:00+00:00"},"published":"2026-10-29","updated":"2026-10-30","sourceUpdated":"2026-10-30T03:56:22.119Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-110193","references":[{"url":"https://www.ibm.com/support/pages/node/7294467"}],"tags":["cve.org"],"epss":0.00777,"epssPercentile":0.55852,"ingestedAt":"2026-11-03T10:42:03.626Z","slug":"CVE-2026-110193","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.\n\n## Affected\n\n- `langflow_oss >= 1.0.0 <= 1.12.8`\n\n## Remediation\n\nUpgrade to Langflow OSS 1.13.0 or later. The latest release is available at  https://github.com/langflow-ai/langflow/releases . Users deploying via pip may upgrade with: pip install langflow --upgrade. Users deploying via Docker should pull the latest tagged image.","depth":"twilight","depthScore":49,"depthScoreParts":{"impact":48.4,"likelihood":0.2,"exploitation":0,"ransomware":0},"changes":[]}