{"id":"CVE-2026-111592","title":"Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors <= 4.17.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via display_name profile-sync into author term name","summary":"The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name (maps to display_name)' parameter in all versions up to, and in…","severity":"medium","cvss":6.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-79"],"vendor":"publishpress","product":"Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors","affected":["co-authors_multiple_authors_and_guest_authors_in_an_author_box_with_publishpress_authors <= 4.17.0"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-01T17:34:24.057048Z"},"published":"2026-10-31","updated":"2026-11-01","sourceUpdated":"2026-11-01T17:44:28.119Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-111592","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/329226bc-7d0e-45e0-8ac0-656517e0e4ca?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/core/Classes/Author_Editor.php#L86"},{"url":"https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/modules/multiple-authors/multiple-authors.php#L5233"},{"url":"https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/modules/multiple-authors/multiple-authors.php#L302"},{"url":"https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.18.0/src/core/Classes/Author_Editor.php"}],"tags":["cve.org"],"epss":0.00193,"epssPercentile":0.09109,"ingestedAt":"2026-11-05T19:30:42.595Z","slug":"CVE-2026-111592","body":"## Overview\n\nThe Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name (maps to display_name)' parameter in all versions up to, and including, 4.17.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the attacker's user account to have a mapped author term, which occurs when an administrator has assigned them as a co-author on content or has enabled automatic author term creation for their role — this mapping is not present by default for new users on a stock install.\n\n## Affected\n\n- `co-authors_multiple_authors_and_guest_authors_in_an_author_box_with_publishpress_authors <= 4.17.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":35,"depthScoreParts":{"impact":35.2,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}