{"id":"CVE-2026-111894","title":"phpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Stored XSS via iframe data: URI","summary":"phpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a stored cross-site scripting vulnerability that allows authenticated content authors to inject JavaScript by embedding iframes with data:text/html sources in FAQ or …","severity":"medium","cvss":5.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-79"],"vendor":"thorsten","product":"phpMyFAQ","affected":["phpMyFAQ >= 3.2.1 < 4.1.9","phpMyFAQ >= 4.2.0-alpha < 4.2.0-beta"],"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-21T21:35:46.990499Z"},"exploitAvailable":true,"published":"2026-10-17","updated":"2026-10-21","sourceUpdated":"2026-10-21T21:36:08.684Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-111894","references":[{"url":"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-fg92-v5rr-4xjq","label":"GitHub Security Advisory (GHSA-fg92-v5rr-4xjq)"},{"url":"https://www.vulncheck.com/advisories/phpmyfaq-3.2.1-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-stored-xss-via-iframe-data-uri","label":"VulnCheck Advisory: phpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Stored XSS via iframe data: URI"}],"tags":["cve.org","exploit-available"],"epss":0.00223,"epssPercentile":0.12816,"ingestedAt":"2026-10-17T19:08:56.937Z","slug":"CVE-2026-111894","body":"## Overview\n\nphpMyFAQ 3.2.1 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a stored cross-site scripting vulnerability that allows authenticated content authors to inject JavaScript by embedding iframes with data:text/html sources in FAQ or News content. Attackers can bypass the hostless media-host allowlist in FaqHelper::cleanUpContent(), which is rendered via Twig's raw filter, to run phishing interfaces or top-frame redirects for viewers.\n\n## Affected\n\n- `phpMyFAQ >= 3.2.1 < 4.1.9`\n- `phpMyFAQ >= 4.2.0-alpha < 4.2.0-beta`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":42,"depthScoreParts":{"impact":29.7,"likelihood":0,"exploitation":12,"ransomware":0},"changes":[{"seq":227433,"id":"CVE-2026-111894","ts":1792621156869,"field":"exploit_available","old":"false","new":"true"}]}