{"id":"CVE-2026-111895","title":"phpMyFAQ 3.2.0 before 4.0.0 and 4.0.2 before 4.2.0-beta Account Takeover via Entra ID preferred_username","summary":"phpMyFAQ 3.2.0 before 4.0.0 and 4.0.2 before 4.2.0-beta contains an authentication bypass in its Microsoft Entra ID login flow, which links users by the mutable preferred_username claim and whose AuthEntraId::create() ignores the duplica…","severity":"medium","cvss":6.8,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","cvssSource":"cna","cwe":["CWE-287"],"vendor":"thorsten","product":"phpMyFAQ","affected":["phpMyFAQ >= 3.2.0 < 4.0.0","phpMyFAQ >= 4.0.2 < 4.2.0-beta"],"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-10-19T14:44:53.067202Z"},"exploitAvailable":true,"published":"2026-10-17","updated":"2026-10-19","sourceUpdated":"2026-10-19T14:46:24.561Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-111895","references":[{"url":"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6hhv-gc4g-f4r7","label":"GitHub Security Advisory (GHSA-6hhv-gc4g-f4r7)"},{"url":"https://www.vulncheck.com/advisories/phpmyfaq-3.2.0-before-4.0.0-and-4.0.2-before-4.2.0-beta-account-takeover-via-entra-id-preferred-username","label":"VulnCheck Advisory: phpMyFAQ 3.2.0 before 4.0.0 and 4.0.2 before 4.2.0-beta Account Takeover via Entra ID preferred_username"}],"tags":["cve.org","exploit-available"],"epss":0.00371,"epssPercentile":0.30837,"ingestedAt":"2026-10-17T19:08:56.936Z","slug":"CVE-2026-111895","body":"## Overview\n\nphpMyFAQ 3.2.0 before 4.0.0 and 4.0.2 before 4.2.0-beta contains an authentication bypass in its Microsoft Entra ID login flow, which links users by the mutable preferred_username claim and whose AuthEntraId::create() ignores the duplicate-login exception while continuing with the existing local account. Attackers controlling an Entra identity in the configured tenant with a matching preferred_username can take over that local account, including super-admin accounts.\n\n## Affected\n\n- `phpMyFAQ >= 3.2.0 < 4.0.0`\n- `phpMyFAQ >= 4.0.2 < 4.2.0-beta`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":49,"depthScoreParts":{"impact":37.4,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":225001,"id":"CVE-2026-111895","ts":1792423928549,"field":"exploit_available","old":"false","new":"true"}]}