{"id":"CVE-2026-111905","title":"phpMyFAQ 3.2.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta IDOR Leaks TOTP Secret via /admin/api/user/data","summary":"phpMyFAQ 3.2.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains an insecure direct object reference vulnerability in GET /admin/api/user/data/{userId}, which returns any user's full faquserdata row, including the live TOTP secret,…","severity":"medium","cvss":6,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L","cvssSource":"cna","cwe":["CWE-639"],"vendor":"thorsten","product":"phpMyFAQ","affected":["phpMyFAQ >= 3.2.0 < 4.1.9","phpMyFAQ >= 4.2.0-alpha < 4.2.0-beta"],"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-21T21:39:44.355200Z"},"exploitAvailable":true,"published":"2026-10-17","updated":"2026-10-21","sourceUpdated":"2026-10-21T21:40:10.782Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-111905","references":[{"url":"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-hp8j-w94m-j5c7","label":"GitHub Security Advisory (GHSA-hp8j-w94m-j5c7)"},{"url":"https://www.vulncheck.com/advisories/phpmyfaq-3.2.0-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-idor-leaks-totp-secret-via-admin-api-user-data","label":"VulnCheck Advisory: phpMyFAQ 3.2.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta IDOR Leaks TOTP Secret via /admin/api/user/data"}],"tags":["cve.org","exploit-available"],"epss":0.00413,"epssPercentile":0.35403,"ingestedAt":"2026-10-17T19:08:56.855Z","slug":"CVE-2026-111905","body":"## Overview\n\nphpMyFAQ 3.2.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains an insecure direct object reference vulnerability in GET /admin/api/user/data/{userId}, which returns any user's full faquserdata row, including the live TOTP secret, without a SuperAdmin or protected-target check. Delegated administrators with user-management rights can read a SuperAdmin's TOTP secret and generate valid codes to bypass two-factor authentication.\n\n## Affected\n\n- `phpMyFAQ >= 3.2.0 < 4.1.9`\n- `phpMyFAQ >= 4.2.0-alpha < 4.2.0-beta`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":45,"depthScoreParts":{"impact":33,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":227432,"id":"CVE-2026-111905","ts":1792621155835,"field":"exploit_available","old":"false","new":"true"}]}